Docker Desktop on macOS unable to start due to malware reportsOperational

Components

Docker Desktop

Locations

Client Machines



January 7, 2025 17:37 PST
January 8, 2025 01:37 UTC
[Investigating] Some users are seeing an issue starting Docker Desktop on macOS where macOS reports that either com.docker.vmnetd or com.docker.socket is malware. The workaround is to: 1. Quit Docker Desktop and check that no remaining docker processes are running using the Activity Monitor 2. Run the following commands: #!/bin/bash # Stop the docker services echo "Stopping Docker..." sudo pkill [dD]ocker # Stop the vmnetd service echo "Stopping com.docker.vmnetd service..." sudo launchctl bootout system /Library/LaunchDaemons/com.docker.vmnetd.plist # Stop the socket service echo "Stopping com.docker.socket service..." sudo launchctl bootout system /Library/LaunchDaemons/com.docker.socket.plist # Remove vmnetd binary echo "Removing com.docker.vmnetd binary..." sudo rm -f /Library/PrivilegedHelperTools/com.docker.vmnetd # Remove socket binary echo "Removing com.docker.socket binary..." sudo rm -f /Library/PrivilegedHelperTools/com.docker.socket # Install new binaries echo "Install new binaries..." sudo cp /Applications/Docker.app/Contents/Library/LaunchServices/com.docker.vmnetd /Library/PrivilegedHelperTools/ sudo cp /Applications/Docker.app/Contents/MacOS/com.docker.socket /Library/PrivilegedHelperTools/ 3. Restart Docker Desktop. 4. If this did not work, update to a newer version and rerun the steps (links here: docs.docker.com/desktop/release-notes) More details in this issue: github.com/docker/for-mac/issues/7527

January 8, 2025 10:41 PST
January 8, 2025 18:41 UTC
[Identified] The root cause has been identified: some files in existing installations are incorrectly signed which can be fixed by copying correctly signed files from the Docker.app application bundle. We are working on a proper fix.

January 9, 2025 23:32 PST
January 10, 2025 07:32 UTC
[Monitoring] Patch releases for Docker Desktop versions 4.32 to 4.37 are now available. Please refer to docs.docker.com/desktop/cert-revoke-solution for more detail. We continue to monitor this situation.

January 13, 2025 07:21 PST
January 13, 2025 15:21 UTC
[Monitoring] We continue to work with our customers and users through the steps described in docs.docker.com/desktop/cert-revoke-solution. We have not identified any new issues but continue to monitor the situation.

January 17, 2025 07:24 PST
January 17, 2025 15:24 UTC
[Monitoring] Feedback from users and customers has been encouraging that the fixes we documented and released are working. Please refer to docs.docker.com/desktop/cert-revoke-solution for detailed information. We continue to monitor this situation.

February 4, 2025 11:04 PST
February 4, 2025 19:04 UTC
[Resolved] This incident is now resolved

Back to current status