·
Vendor issue resolved
Resolved
Monitoring
Provider seems to have fixed the issue.
Investigating
Our third party email provider is having issues. We're investigating workarounds.