Resolved
The issue has been resolved. Docker Build Cloud availability is back to normal.
Identified
We have identified a capacity issue in Docker Build Cloud related to an underlying Cloud Service Provider. A small subset of users may see delays in obtaining a builder.